BenQ W1070 Firmware Upgrade, extra 3D support…

Enjoy 1080p Full-HD image projection up to 200” in the comfort of your living room with the W1070 Home Entertainment Projector. You’ll be captivated by brilliant image performance featuring a 10,000:1 contrast ratio and a 2000 ANSI Lumens brightness. And after this firmware update your W1070 supports even more 3D resolutions and refresh rates.

Requirements

!!! I am not responsible for Failed Firmware Updates, Failed updates are not covered by warranty so continue on own risk !!

Firmware Update

*Still no 1080p 60hz, try changing your HDMI cable.

W10701.08FW

Unable to select SBS on 1080p 60Hz?
Firmware Changelogs

benq60hz1080p3d

195 thoughts on “BenQ W1070 Firmware Upgrade, extra 3D support…

  1. Note that before running the flash loader you have to put the projector in firmware download mode by holding the power and auto buttons while plugging it in until the red light holds.
    This info can be found in the instructions from the ftp site.

  2. Nice work – the process of upgrading from 1.05 to 1.08 worked perfectly fine.

  3. Firmware 1.08
    – Noise improvement / 1080p greenish problem via HDMI/VGA signal.
    – Add 3D support timing: 1080p 60Hz SBS

    My media player is outputting 1080p 60Hz SBS and base on the release firmware that is fixed.

    Side by side in the BenQ 3D menu is still grey out.

    Any Help.

  4. Side by Side, Top & Bottom and frame packing all working well with 1.08. Easy upgrade if instructions followed. Thanks – all 3D films & MKV work now

  5. Oh, oh… i “tried” to update from 1.07 to 1.08 and it failed. The red LED stays on. The update procedure seemed to be good. Is there any idea to awake the benq again?
    Regards, Mike

  6. Hi,

    I’m really enjoy by your post. I’ve just one question, is there a different firmware for the benq w1090 ? It’s really the same projector but with different lens.

    Thanks for all,
    Sylvain

  7. Great guide. But I was just wondering, am I the only one who broke my lightbulb? Because of overheating. I guess it was because of my some problems i had connecting via USB that did it, because sometimes i just plugged the stick out so the fan didnt cool it off. If you can do this upgrade without the lightbulb inside would I recommend taking it out, its 2 screws – verry simple. Maybe its just because im to stupid to make it work the first time. I hope to help someone from burning your lightbulb off. Its a lot of money for a new. I got the red lamp sign afterwards and there were no light from the PJ, so i hope its “just” the lightbulb.

    • I have never had a problem with overheating, you should disable “quick cooling” (or something like that) in settings and don’t unplug your beamer before the fans have stopped.

  8. Which flashdeviseparameters.txt to I copy to the installation folder? There wre two in the download package one in the BENQ W1070 1.08 firmware package folder and one in the DDP442X Download_Tool Folder both seem to be a bit differant?

  9. Am I crazy or is the main bundle link going to spam and the ftp sites have all changed the login credentials?

    If so and anyone has a copy they can repost, I would be most grateful.

    Thanks,

    Cam

  10. Steven pls can you tell us how to access BenQ FTP site? I’ve got a different projector MH680
    Thanks

  11. Anybody have instructions on how to update the firmware on W1080ST projector. I am currently on 1.02.

    • Instructions should be the same however you will need an other firmware file (not sure if this firmware is stil available since benq changed their FTP password)

      • I contacted BenQ support and they want me to send the projector back to upgrade it from 1.02 to 1.08. I guess I will have to go that route since the download links are shut down 🙁

        • it’s a shame they don’t mail the update with a guide or so. sending your beamer in for a simple firmware upgrade is just stupid (from benq)

  12. Hi, does it matter which firmware you are upgrading from, I am 1.01, can I go straight to 1.08? thanks

  13. Hi I get to the driver download bit but nothing is happening, also when I copy the text file where do I use it

  14. Colin, What URL did you use to download the files. I need the ones for W1080ST but all the ones that I tried do not work any more.

  15. clownfish360 I used the link on this page, they are for w1070. I am using window 8 but the drivers on the communications page are not supported on my computer could this be why nothing happens when I plug the projector to the computer. can anybody help me

  16. Colin,
    I have the same problem. My drivers never load from the DLP composer. I’m running Windows 7. My pc recognizes the w1070 when it’s in presentation mode, but does not recognize the pj for the update. I have the pj in the correct state with the red light status lit, but DLP never loads up to do the firmware install.

  17. After upgrading to 1.08 I can shut down the beamer with remote. Thank you so much!

  18. I followed the procedure but cannot find the flash image file in C drive or elsewhere. I reached the stage of installing the drivers but cannot proceed further because I cannot locate the flash image file on my computer. Am I required to download that file from another location?

      • Yes it was very much there but somehow I missed seeing it. Anyway, with red light glowing, I became restless and called BenQ and managed to convince them with great difficulty to send me the firmware file. They sent me a file named W1070_v108_7C4B.img, which works fine.

  19. Since I was not able to find the firmware files for my w1080st I called BenQ and they had me send the projector back to them for an upgrade. Only took about a week of down time and now I have the latest 1.05. Works great now.

  20. Hi,

    have trouble with updating my beamer. Following message appears when I start download “Error: Selected Boot Loader Size (try 128kb) or uncheck Skip Boot Loader Box.” Power LED is RED and Beamer Drivers found via USB! Any Idea what’s wrong?

  21. btw, I have a W1070+W (European Model). Do I need another Firmware? Mine is atm V1.03. Anyone can help?

    • The firmware in this guide is for the W1070, NEVER try installing this firmware on any other model… this will result in a bricked beamer with void warranty.

      • you can try emailing benQ and ask for the firmware file.. the process should be the same. Benq probably refuses this… however Benq will probably update your firmware if you send it in for warranty and ask them specifically to update the beamer

  22. the process of upgrading from 1.05 to 1.08 worked perfectly – many thanks from austria

  23. Worked well,
    thank you and thank you to benq for continuing update this fantastic vpr

  24. Please, I also need to know if this also works for the W1070+ or only for the version without the ‘plus’.
    Thanks

    • I’m sorry but you should better not try this update on your model, there is a big chance your beamer requires different firmware than the original w1070. Trying & failing with this firmware will break your beamer AND void your warranty.

    • This firmware will not work with the W1070+ model, this model has some new features that are not included in the w1070’s firmware.

  25. I just updated from 1.07 to 1.08. It partly solw my problem with pink-green screen (It happen when I connect amplituner HK 255 with Benq W1070 via 10m HDMI cable). Thanks 🙂

  26. Hi, Steven . . .

    Thanks for providing all of the support for the update. I’m having a problem getting Windows to install the drivers. The red light on the projector panel is lit, but the “driver installation box” doesn’t open. Everything leading to this stage I’ve checked and double checked – and all is as you’ve instructed.

    After clicking “ok” when getting the “error: cannot open the USB driver” warning, I can’t get the drivers – even through the red light on the W1070 is lit. I assume that I should be leaving the DLPLite program running while waiting for the “driver installation box” to appear.

    I am using the FlashDeviseParameters.text file that is 42.0 KB (43,079 bytes) in size. This is the one found OUTSIDE of the” DDP442X Download_Tool folder”.

    Do you know what I might be doing incorrectly?

    Can you offer any advice?

    Many thanks . . .

    Ian

    • Did you find a solution im having the exact same issue?
      Lachlan

  27. In my posting from yesterday, I didn’t mention that I am using a Windows 8 laptop — and the firmware on my BenQ w1070 is currently 1.04. I am hoping that I can get my projector updated to 1.08. Would attempting the update with another laptop running Windows Vista potentially work?

    Thanks.

    Ian

  28. It worked . . . I think. I was finally able to update from 1.04 to 1.08 tonight. What’s weird is that I never did see the box open up showing the installation of the USB drivers. I suspect this happened so quickly, or when I was looking away. Tonight when I used the Windows Vista laptop (in place of the WIn 8 laptop I tried last night), I wondered if the drivers may have somehow installed . . . so I continued with the update and all proceeded as expected.

    I checked my f/w version, and after the update the unit shows I’m running 1.08. I never expected to be so excited about an update!!! I still can’t figure out why I didn’t see the box open showing the installation of the USB drivers??? Nonetheless, I doubt I could have proceeded with the install if the drivers weren’t installed — so I assume all is good.

    I look forward to seeing if I notice any of the benefits of moving from 1.04 to 1.08.

    So far, all seems good. Fingers crossed.

    Ian

  29. I cannot download from the link, when I click “Skip Ad” from Adf.ly it comes with error everytime. Can anyone give me an alternative link please ?

  30. Hello, i just updated my second W1070 and everithing works perfect now. No more Grenish HDMI Problems.Thank You very mutch for this Support. Joe from Switzerland

  31. First, I am very thx for the firmware update. I updeted my projector yesterday succesfully. There was the original problem, that I could be choose the Top and Bottom (TAB) mode.
    I know that the side by side mode works 1080i only with the 1.06 firmware but I cannot convert the video to that mode. I hoped that this firmware will solve this problem. Unfortunately I can still choose the TAB mode only. I tried to play 720p, 1080p video but I cannot choose the TAB mode only.

    Does Anybody have any idea?

    I am very thx for helping
    Big thx for Steven too

    Sandor from Hungary

    • La mise à jour en 1.08 permet d’avoir accès au Top and Bottom si le lecteur auquel est branché le w1070 le permets. Pour moi j’ai branché un petit LG BD 325, il a une prise USB sur laquelle j’ai connecté un Disque Dur qui stock tous mes films 3 d. Mkv et autres format, en Side by Side et Top ans Bottom.
      Dans cette configuration, le menu 3d du w1070 est entièrement accessible et je peux lire tous mes films 3d quelque soit le format…..

      Mario de France

      The update 1.08 allows access to the Top and Bottom if the player is connected to which the w1070 permit it. For me I plugged a small LG BD 325, it has a USB port which I have connected a HDD that stores all my movies 3 d. MKV and other format by Side by Side and Top Bottom years.
      In this configuration, the w1070 3d menu is fully accessible and I can read all my 3d movies in any format … ..

      Mario de France

  32. If you don’t have a real Windows 7 PC, you can also install Windows 7 in VMware and try it in there. It took me almost 30 minutes though through VMware, but it works. DO NOT USE VIRTUAL PC – I had many printers who were just confused by messed USB communication.

  33. Hi

    I have benq w1070+ currently on 1.03 is there any way to update to 1.08 so i can use my 3d feature ?

    Thanks

  34. Merci pour ce tutoriel excellent. Mise à jour faite sans difficultés de 1.05 vers 1.08 pour W1070. Pour la 3d, j’ai désormais accès aux options qui étaient grisées auparavant. Top ans Bottom et Frame. Merci encore pour votre travail Steven…

    Thank you for this excellent tutorial. Updated done without difficulties 1.05 to 1.08 for W1070. For the 3d, I now have access to options that were previously grayed out. Top and Bottom Frame years. Thank you again for your work … Steven

  35. now how to roll back this to 1.07,
    the projector overheats and turns off, red lamp led is on, with the new lamp.

  36. bonjour
    j’ai mis a jour mon w1070 en version 1.08 mais impossible de choisir side by side en 1080p 60Hz la case reste grisee

    hello
    I updated my w1070 1.08 but can not choose version side by side in 1080p 60Hz box remains grayed

    • The beamer does support 1080p 60Hz but does your input device? I’ve also noticed some devices just won’t work or you may be using an older HDMI switch?

      Le projecteur ne supporte 1080p 60Hz , mais fait votre périphérique d’entrée ? Je ai aussi remarqué que certains appareils ne va pas fonctionner ou si vous utilisez peut-être un commutateur HDMI plus ?

    • same here, after updating to 1.08 – I can’t see any difference between 1.08 and 1.07, same settings, no option to chose 1080p/60fps

      • the 1080p 60Hz SBS will not work for all devices, you could always try using 1.4 HDMI cables and don’t use outdated HDMI switches…

        • I checked my HDMI cable today, it is Supra HD5 digital video cable.
          “quoting”
          Tested in compliance with HDMI v1.4a testing specifications and as such, it is said to be compliant with all aspects of the tests.

          Not only are Supra HD5 cables backwardly compatible with previous generations of hardware, but that they are also suitable for use with the new generation of equipment, such as Smart TV’s and set top boxes requiring internet access (if said equipment uses the HDMI socket for this function – otherwise a network cable may be required to connect directly to your router).

          Depending on the source resolution, the length of the cable and the receiving hardware, resolutions of 720p, 1080i, 1080p and anything up to “4k” can be carried by the HD5 cable, from sources such as set-top boxes, games consoles and 5″ silver disc players.

          My pc hardware is 2 generations back, but still keeps up well with the new generation:

          Asus rampage 3 formula
          cooler master gold 1200
          i7-990x
          evga gtx780 sc acx
          12gb ram
          Benq W1070 beamer.

          I don’t know what’s going on here, may be I”m doing something wrong, but I don’t think so unless you correct me.

  37. j’utilise comme source un minix minix neo x8-h plus et un lecteur bluray Panasonic 3d avec un cable hdmi 1.4 et des mkv 3d side by side

    I use as a source minix minix neo – x8 h more and a Panasonic 3d bluray player with HDMI 1.4 cable and mkv 3d side by side

    • not sure why it doesn’t work, you could try a laptop…

      ne sais pas pourquoi cela ne fonctionne pas , vous pouvez essayer un ordinateur portable …

  38. ok merci pour votre aide je vais essaye

    ok thank you for your help I will try

  39. quand j ai fait la mise a jour j’ai du mettre une rallonge usb au cable car il etait trop court c’est peut etre sa le probleme non ??

    when I made the update I had to put a usb extension cable to because it was too short it may be its not the problem ??

    • if your beamer’s system information tells the firmware is 1.08 it’s ok however i would not recommend using a usb extension cable

      si le système d’information de votre projecteur indique le firmware est 1.08 ce est correct, mais je ne aurais pas recommande d’utiliser un câble d’extension USB

    • if your beamer’s system information tells the firmware is 1.08 it’s ok however i would not recommend using a usb extension cable

      si le système d’information de votre projecteur indique le firmware est 1.08 ce est correct, mais je ne aurais pas recommande d’utiliser un câble d’extension USB

  40. j’ai essayer avec un pc et j ai toujours le meme probleme en 1080i 60hz c’est ok mais en 1080p 60hz ca ne fonctionne pas j’ai toujours la case cote a cote qui est grisee serait il possible de recommancer la mise a jour ??

    I try with a pc and I still have the same problem in 1080i 60hz is 60hz 1080p ok but it does not always work I document box beside it is dimmed would it be possible to update the recommancer ??

    • no need to reinstall 1.08, this is normal behavior… If you want better compatibility 1080p 60Hz you will have to ask BenQ to create a better update.

      pas besoin de réinstaller 1,08 , ce qui est un comportement normal … Si vous voulez une meilleure compatibilité 1080p 60Hz , vous aurez à demander BenQ pour créer une meilleure mise à jour .

  41. You made a small typo, it is program files 86 not 84. In the line 64bit : c:/program files(x84)/DLP Composer Lite 11.0.1.
    Also it didnt take 5 min for the beamer to do the setting stuff. Perhaps change that to 2 min.
    The firmware did update, thanks a million!

  42. Bonjour
    J ai acheter un autre câble hdmi ( Monster câble hdmi 3D ) et maintenant j ai bien 1920×1080 60hz en 3D cote a cote merci Steven pour votre aide et pour la mise a jour

    hello
    I ve buy another HDMI cable ( HDMI Cable Monster 3D ) and now I ‘m 1920 × 1080 60Hz 3D side by side Steven thank you for your help and for the update

    • Great to know the problem may be the HDMI cable, everyone should try multiple HDMI cable’s to try out 1080p 60hz.

      Grande pour connaître le problème peut être le câble HDMI , tout le monde devrait essayer câble HDMI multiples de d’essayer 1080p 60Hz .

  43. bonjour
    je pence que mon vidéoprojecteur doit avoir un problème car plus moyen d’avoir la 3d cote a cote en 1080p 60Hz ca fonctionnait correctement et aujourd’hui cote a cote est de nouveau grisée .

    hello
    I think my projector must have a problem as more way to have 3D side by side in 1080p 60Hz AC worked well and now side by side is again dimmed.

  44. Great work! Thank you for the files and the detailled description. The update went fine!
    But unfortunately 1080p 60Hz still doesn’t work with 2 different players and 2 differenz cables (for 3D). According to posts on some German sites this is because 1080p 50/60Hz is not defined in HDMI 1.4a and you have to put your player to 24Hz. I will try that later.

    • well i’m actually using a old 1.3 HDMI switch for my ps3 and pc… beamer allows 60hz 1080p 3D on both, maybe it’s just older cables we need to test..

      • Thanks Steven, for taking your time to post such detailed instructions. I was able to successfully update to 1.08!

        Now, the problem is, I have a source (Onkyo HTS 3500 + Chromecast) that outputs 1080P, 60Hz. But the 3D SBS is greyed out. Only Top and Bottom is available.
        (I am not sure how to change the source resolution. If I can, I would)

        I have a 30ft HDMI cable rated to support that resolution. Link here (http://www.monoprice.com/Product?c_id=102&cp_id=10255&cs_id=1025506&p_id=9430&seq=1&format=2).

        Any ideas?

        • This is a known problem and you are not the first to post about this problem. There is on clear solution on this problem however some users posted that changing the HDMI cable fixed their issues.

  45. Attention

    In the projector’s menu in section information, appear:

    Color system = YUV – SBS 3D is grayed

    Color system = RGB – SBS 3D is enabled

    • Hi, Carlos.
      On the computer, in the control panel of ATI or NVIDIA click on “my monitors” and then click “pixel format” or “Color Manager” or “color system” or “pixel color”, may appear written one of these ways I wrote.
      Change YCbCr for RGB, and restart the PC.

      note:
      Advise update the graphics card driver

  46. I was able to do the update and it showed completed However, the power light is solid red, I’m unable to get the projector to power on properly. Everything I found says that the solid red light means that there could be an issue with the fans are not working. Have you heard of anyone else having that problem? do you have any suggestions?

    Thanks for you time.

    • Haven’t had any reports on the update failing yet, you could search the manual or google on the red light, If you did the update as described it should have installed correctly. Have you tried unplugging it/letting it cool down first before turning it on?

      • Thanks, the manual says that it has to do with the fans not working inside the projector. I tried leaving it unplugged overnight but that didn’t work, the update was successful, it could have been coincidental, I’m going to RMA it back to Benq which would probably be cheaper than buying a new one.

        Thanks for responding.

  47. Hi guys. Great guide can you confirm the hdmi port is ‘upgraded’ to a 1.4b port after this update? I am wanting to play 3d games on my pc at 1080p/60

      • Hi, so 1080/60 30 gaming means sbs in (so 2 *) 720 right? It is still not possible te game 3d in full HD 60 hz right? thats only in 24hz?

        If you tell me it is now possible to game in full hd 60 hz I will lose my mind!

        tnx for the reply 🙂

        • side-by-side or top-bottom 3d will indeed render 2 720p videos, however frame packing will display the hole 1080p image if i’m remembering correct. Not sure what is needed to enable frame packing on pc’s as I haven’t seen it enabled yet.

          • Yeah, it’s totally possible but they wont install it. It’s been frustrating me for years. 3d gaming isn’t important enough I guess. Tnx for the reply man!! 🙂

  48. Hi,i need your help steven .I have the benq w1070 with latest firmware update 1.08 i tried trough play station 3 with hdmi cable, with my computer hdmi to hdmi ,dvi to hdmi ,mini display to hdmi from laptop and i cant get 1080p 60 hz 3d is there any soloution … with RGB cable can i get this frame ? i dont know what i am doing wrong 🙁

  49. i have read all the forum .. meaby my hdmi cable it’s not v1.4b but my mini display to hdmi has to be ok … i am using power dvd 14 and it says at 3d option max resotution 1080p 24 hz when i go to windows screen resolution to switch at 1080p 60 hz and use apply my projector can’t wokr with that and it reset to 1080p 24 hz 🙁 can saw some how your set up .. it would be very helpfull

    • 1080p 60hz was always available, its officially supported by benq from the first firmware. your 3D is probably working but the problem is something else. you should play the SideBySide or Top/Bottom movie in a normal video player so you have 2 screens, now press the 3d settings button on your remote., enter 3D Mode and choose your type of movie, now the screen should be blurry as the beamer itself split the input video & puts these 2 new layers over eachother. in the previous firmware the 3d options would be grayed out when your resolution was 1080p 60hz but now all that has changed is the 3D options are now available in 1080p 60hz so put on your (active) glasses & watch 3D! 🙂

  50. i test it with windows 7 and its works but with windows 8.1 can’t make it 1080p 60 hz 3d that was the problem i think

  51. HI there
    I was wondering if this update can be done with a computer running Win 10 ??
    Or should I try to get hold of a win vista or 7 computer ???

  52. Hi, thanks for the guide and the files. When I follow the guide everything goes smoothly until I press the last button “start download”. then i get this log:

    Loaded flash device info from: FlashDeviceParameters.txt
    Error: Unable to enter device programming mode.

    The projector is in the correct mode with the solid red light. Ive tried 2 different computers (both macs running windows xp on virtual box). The VMs see the projector and the drivers install, and resetting the BUS works too, just not the upload. Any ideas?

    Thanks

    • you should NEVER use a virtual machine to program a chip. the danger of bricking your device is too high, try a normal windows pc & it should work just fine 🙂

  53. Factory Reset of W1070

    How do I get to Factory menu and do hard reset of my Projector. I had the colorwheel and Lamp changed. The color/tint is messed up when I use HDMI (reddish purple or blue) but Ok when I use S-Video/Composite.

  54. I upgraded w1070 from 1.06 to 1.08 following the instructions/files here, but I am still not getting side by side @1080p 60hz. I am getting side by side on 1080p 24hz and 1080i 60hz. After upgrade my fw says 1.08 and screen flickers when I turn off the 3d on w1070.

  55. Big thanks from the Czech republic. Following the instructions everything simple and functional.

  56. PLEASE HELP ; following the firmware update (everything went well) the projector is shutting down with the red light after few minutes and impossible to change the lamp alimentation (the menu is grey out now). Please help me!

      • Thanks for your answer. I was in 1.06 before. I discovered that the menu is grey out depending on the source: direct connexion with blu ray player, lamp menu is available and projector working for 30 minutes, connexion via hc ampli, menu grey out and vp working for only few minutes… Not sure at all indeed is linked to firware upgrade… Lamp seems ok before shutting down…. Any clue will be appreciated!

        • ok, you should try enabling “high altitude” mode, this should keep your beamer cooler, in some cases the option stays grayed out, in this case the problem is with the output signal of your computer, try changing your output mode.

          • Already tried… No success and the temp indicator is ok, this is the lamp indicator in red. I tried several output without result and it was working previously the last 2 years…

              • also tried… I bought a new lamp yesterday and I had once the same issue but it has worked after that during 2 hours without issue…. so I afraid I need to send it back to benq out of warranty (2 years and few weeks…) I afraid it will cost a lot…. grrrrr. very disapointed by BENQ!

                • I’m sorry to hear about your problem :(, when sending it back you can explicitly ask to update the firmware..

  57. This was exactly the trick. Finally, I found a post that was based on actual fact and experience. Addressing the drivers was the glitch that current Windows users need, and is not addressed anywhere else I looked. Thanks for posting this info and supplying relevant files that avoid the making of a brick.

  58. Dear Steven, where can I get official firmware files? Is there newer version than 1.08?

    • the official 1.08 firmware files are in the post, you can’t officially obtain the update as benq only updates the firmwares when returning your beamer. I don’t know if there are any newer firmwares but I would guess not :s

      • Thank you Steven for reply. I know about the download link, but it’s dead, could you please reupload it?

          • Firefox failed to open the link, opera could. Thank you. As I understood, BenQ doesn’t suggest to update firmware by users because it can be failed, other way they would provide it on their website, am I right? Someone said that he downloaded it from official website years ago.

            • :p that’s true, benq accidently left their internal servers open to the outside so all firmwares were available for a short period of time, when benq noticed they took it offline.

              • I see. My current firmware is 1.05. Why I wanted to update it is – when I watch blu-ray movies I press play button when it goes from menu to movie it makes long “HDMI source search” about 10 seconds! It annoys me very much because I hear the sound from the home theater but see blank screen while it searches HDMI! Pay attention that I have only ONE HDMI connected! And no other cables like VGA, RCA! And it stupid that it makes HDMI 1 search each time again and again! So after movie finishes, it backs to menu, so I want to see some bonus features which are let say 2-3 minutes long, so each time when I choose from menu which bonus to watch it makes “source search” again, I wanna watch trailer, I choose the trailer, again it makes “HDMI source search” I need to wait 10-12 seconds and I miss the beginning of the trailer which is 1-2 minutes long. You must understand how annoying this is! I tried to disable this function from menu, and stick with HDMI 1 without any searching, but that’s not possible! So I guess, maybe newer firmware stop this headache?

                • Hmm sounds very annoying indeed, I can confirm that after updating to 1.08 the source search was a lot quicker. just thinking with you.. does the resolution change when going from the menu to the movie or does 3d gets enabled? when connecting to a regular tv, does the “signal” shortly interrupt like it does on the beamer (may be your player)? very unlikely but could you change the hdmi cable, i”ve noticed some older cables randomly losing signal for a few seconds. also, my beamer shortly goes black when turning on my tl-lights or some heavy load. it could even be your active subwoofer shutting down or starting up?

  59. No, resolution doesn’t change and 3D doesn’t get enabled. I don’t have TV to check it, but I guess – yes, the signal interrupts for about 0.5 seconds to show the image and benq starts searching. Isn’t it normal for other players when they go from menu to chosen content? I have 2 HDMI cables (1.4b version) 9 meters long inside my ceiling, I’ll try to connect other one, but feels like I’ll get no difference.

    • I just checked @ home, there is an option “auto source search”, you could disable this and try again? the auto search is quite slow for me.. it feels like it just loops trough the list of sources, waiting for signal for about 2 seconds and than check the next one.. this way it takes up to 10 seconds (like you said) until it checks your hdmi source again.

      • Thank You Steven for reply. I just checked and “auto source search” is off by default! I made a mistake saying I wanna stick with HDMI 1 and it makes searching. Actually it makes searching within HDMI 1, which is connected. So your words about loosing signal is true. It looses signal and writes “HDMI 1 source searching. Source detected!”. Actually there’s no need to search it again and again, because my player is fast enough, when I press play button after 0.5 seconds I hear the voice of the video and it plays the content, but benq makes searching and finds it after few seconds and after 10 seconds image appears on the screen. Don’t you have this problem or yours looses the signal too but finds it much quicker because of the latest firmware?

Leave a Reply